summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2021-06-23 23:10:20 +0100
committerKieran Bingham <kieran.bingham@ideasonboard.com>2021-06-25 16:11:11 +0100
commitfc9b226d19b59e965b1746ba5dc6fc603de3b591 (patch)
tree6a50ea9111f00f56d4bf08431cfd3e7db1c876fc /test/meson.build
parent5c01d541208d32265d398e07085bcdf4606cc1f5 (diff)
test: Ensure LIBCAMERA_BASE_PRIVATE isn't public
If LIBCAMERA_BASE_PRIVATE is ever exposed on the libcamera public dependencies, then the private.h header protection will be circumvented. Provide a test which will fail (at compile time) if the LIBCAMERA_BASE_PRIVATE define ever leaks to the public dependencies. Reviewed-by: Paul Elder <paul.elder@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index 73eb44d0..2c3e7654 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -25,6 +25,7 @@ subdir('v4l2_videodevice')
public_tests = [
['geometry', 'geometry.cpp'],
+ ['public-api', 'public-api.cpp'],
['signal', 'signal.cpp'],
['span', 'span.cpp'],
]