summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2021-06-23 23:19:20 +0100
committerKieran Bingham <kieran.bingham@ideasonboard.com>2021-06-25 16:11:11 +0100
commit5c01d541208d32265d398e07085bcdf4606cc1f5 (patch)
tree442688b436d1938e2477e4014877ed65bf1f10ee /test/meson.build
parentff7832d2cd9beb586987fb9619d0e734771583b6 (diff)
libcamera: rename public libcamera dependency
Now that we have a libcamera_private, make the public only dependency libcamera_public so that it is clear which interface is being linked. Reviewed-by: Paul Elder <paul.elder@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/meson.build b/test/meson.build
index b8615e0f..73eb44d0 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -55,7 +55,7 @@ internal_tests = [
foreach t : public_tests
exe = executable(t[0], t[1],
- dependencies : libcamera_dep,
+ dependencies : libcamera_public,
link_with : test_libraries,
include_directories : test_includes_public)