summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJacopo Mondi <jacopo@jmondi.org>2019-10-26 22:49:42 +0200
committerJacopo Mondi <jacopo@jmondi.org>2019-11-14 10:50:00 +0100
commit831c82fbbd29b3f689f2914de8466d3b5f5330e6 (patch)
tree7c1eb42738dc68b15fa14c9afb5e7f42ada40d7e /meson.build
parentf31261f8ecba6e1b7b1ff8d199e6e6443a661e25 (diff)
Add example application main file
Signed-off-by: Jacopo Mondi <jacopo@jmondi.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 042048b..573b30c 100644
--- a/meson.build
+++ b/meson.build
@@ -1,6 +1,7 @@
project('elce-cam', 'c', 'cpp',
default_options : [
'werror=true',
+ '-Wno-unused-parameter=true',
'warning_level=2',
'cpp_std=c++11',
])
@@ -9,8 +10,10 @@ cc = meson.get_compiler('c')
config_h = configuration_data()
# elce-cam source files
+# elce-cam.cpp is the fully commented application
+# mini=elce.cpp is for live coding during ELC-E 2019
src_files = files([
- 'main.cpp',
+ 'elce-cam.cpp',
])
# Point your PKG_CONFIG_PATH environment variable to the
@@ -19,6 +22,9 @@ libcamera_deps = [
dependency('camera', required : true),
]
+cpp_arguments = '-Wno-unused-parameter'
+add_project_arguments(cpp_arguments, language : 'cpp')
+
# elce-cam executable
elce_cam = executable('elce-cam', src_files,
dependencies : libcamera_deps,