summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJacopo Mondi <jacopo@jmondi.org>2019-10-26 22:49:24 +0200
committerJacopo Mondi <jacopo@jmondi.org>2019-10-26 22:49:24 +0200
commitf31261f8ecba6e1b7b1ff8d199e6e6443a661e25 (patch)
treefe4c66d3dbb9a12dab87ed78e8b7439432d42ceb /meson.build
Add meson.build file
Signed-off-by: Jacopo Mondi <jacopo@jmondi.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build25
1 files changed, 25 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..042048b
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,25 @@
+project('elce-cam', 'c', 'cpp',
+ default_options : [
+ 'werror=true',
+ 'warning_level=2',
+ 'cpp_std=c++11',
+ ])
+
+cc = meson.get_compiler('c')
+config_h = configuration_data()
+
+# elce-cam source files
+src_files = files([
+ 'main.cpp',
+])
+
+# Point your PKG_CONFIG_PATH environment variable to the
+# libcamera install path camera.pc file ($prefix/lib/pkgconfig/camera.pc)
+libcamera_deps = [
+ dependency('camera', required : true),
+]
+
+# elce-cam executable
+elce_cam = executable('elce-cam', src_files,
+ dependencies : libcamera_deps,
+ install : false)