summaryrefslogtreecommitdiff
path: root/test/v4l2_videodevice/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/v4l2_videodevice/meson.build')
-rw-r--r--test/v4l2_videodevice/meson.build18
1 files changed, 18 insertions, 0 deletions
diff --git a/test/v4l2_videodevice/meson.build b/test/v4l2_videodevice/meson.build
new file mode 100644
index 00000000..76be5e14
--- /dev/null
+++ b/test/v4l2_videodevice/meson.build
@@ -0,0 +1,18 @@
+# Tests are listed in order of complexity.
+# They are not alphabetically sorted.
+v4l2_videodevice_tests = [
+ [ 'double_open', 'double_open.cpp' ],
+ [ 'formats', 'formats.cpp' ],
+ [ 'request_buffers', 'request_buffers.cpp' ],
+ [ 'stream_on_off', 'stream_on_off.cpp' ],
+ [ 'capture_async', 'capture_async.cpp' ],
+ [ 'buffer_sharing', 'buffer_sharing.cpp' ],
+]
+
+foreach t : v4l2_videodevice_tests
+ exe = executable(t[0], [t[1], 'v4l2_videodevice_test.cpp'],
+ dependencies : libcamera_dep,
+ link_with : test_libraries,
+ include_directories : test_includes_internal)
+ test(t[0], exe, suite : 'v4l2_videodevice', is_parallel : false)
+endforeach