summaryrefslogtreecommitdiff
path: root/test/v4l2_videodevice/meson.build
diff options
context:
space:
mode:
authorJacopo Mondi <jacopo@jmondi.org>2019-06-12 13:09:57 +0100
committerJacopo Mondi <jacopo@jmondi.org>2019-06-19 15:46:44 +0200
commit3a6c4bd146cc6647daf458bbc048bd861e702f62 (patch)
treefe44a23f524bd1d82b541985bddf83a275ae725a /test/v4l2_videodevice/meson.build
parent20807a8c17e629b93d293ef0a0bdbd686ce84823 (diff)
libcamera: Rename V4L2Device to V4L2VideoDevice
In preparation of creating a new V4L2Device base class, rename V4L2Device to V4L2VideoDevice. This is a project wide rename without any intended functional change. Signed-off-by: Jacopo Mondi <jacopo@jmondi.org> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'test/v4l2_videodevice/meson.build')
-rw-r--r--test/v4l2_videodevice/meson.build18
1 files changed, 18 insertions, 0 deletions
diff --git a/test/v4l2_videodevice/meson.build b/test/v4l2_videodevice/meson.build
new file mode 100644
index 00000000..76be5e14
--- /dev/null
+++ b/test/v4l2_videodevice/meson.build
@@ -0,0 +1,18 @@
+# Tests are listed in order of complexity.
+# They are not alphabetically sorted.
+v4l2_videodevice_tests = [
+ [ 'double_open', 'double_open.cpp' ],
+ [ 'formats', 'formats.cpp' ],
+ [ 'request_buffers', 'request_buffers.cpp' ],
+ [ 'stream_on_off', 'stream_on_off.cpp' ],
+ [ 'capture_async', 'capture_async.cpp' ],
+ [ 'buffer_sharing', 'buffer_sharing.cpp' ],
+]
+
+foreach t : v4l2_videodevice_tests
+ exe = executable(t[0], [t[1], 'v4l2_videodevice_test.cpp'],
+ dependencies : libcamera_dep,
+ link_with : test_libraries,
+ include_directories : test_includes_internal)
+ test(t[0], exe, suite : 'v4l2_videodevice', is_parallel : false)
+endforeach