summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build9
1 files changed, 6 insertions, 3 deletions
diff --git a/test/meson.build b/test/meson.build
index 189e1428..8b6057d4 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -69,6 +69,7 @@ internal_tests = [
{'name': 'signal-threads', 'sources': ['signal-threads.cpp']},
{'name': 'threads', 'sources': 'threads.cpp', 'dependencies': [libthreads]},
{'name': 'timer', 'sources': ['timer.cpp']},
+ {'name': 'timer-fail', 'sources': ['timer-fail.cpp'], 'should_fail': true},
{'name': 'timer-thread', 'sources': ['timer-thread.cpp']},
{'name': 'unique-fd', 'sources': ['unique-fd.cpp']},
{'name': 'utils', 'sources': ['utils.cpp']},
@@ -91,7 +92,7 @@ foreach test : public_tests
link_with : test_libraries,
include_directories : test_includes_public)
- test(test['name'], exe)
+ test(test['name'], exe, should_fail : test.get('should_fail', false))
endforeach
foreach test : internal_tests
@@ -105,7 +106,7 @@ foreach test : internal_tests
link_with : test_libraries,
include_directories : test_includes_internal)
- test(test['name'], exe)
+ test(test['name'], exe, should_fail : test.get('should_fail', false))
endforeach
foreach test : internal_non_parallel_tests
@@ -119,5 +120,7 @@ foreach test : internal_non_parallel_tests
link_with : test_libraries,
include_directories : test_includes_internal)
- test(test['name'], exe, is_parallel : false)
+ test(test['name'], exe,
+ is_parallel : false,
+ should_fail : test.get('should_fail', false))
endforeach