summaryrefslogtreecommitdiff
path: root/test/camera/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/camera/meson.build')
-rw-r--r--test/camera/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/test/camera/meson.build b/test/camera/meson.build
new file mode 100644
index 00000000..186ba211
--- /dev/null
+++ b/test/camera/meson.build
@@ -0,0 +1,12 @@
+# Tests are listed in order of complexity.
+# They are not alphabetically sorted.
+camera_tests = [
+ [ 'configuration_default', 'configuration_default.cpp' ],
+]
+
+foreach t : camera_tests
+ exe = executable(t[0], [t[1], 'camera_test.cpp'],
+ link_with : test_libraries,
+ include_directories : test_includes_internal)
+ test(t[0], exe, suite: 'camera', is_parallel: false)
+endforeach