summaryrefslogtreecommitdiff
path: root/test/camera/meson.build
diff options
context:
space:
mode:
authorNiklas Söderlund <niklas.soderlund@ragnatech.se>2019-02-05 21:32:04 +0100
committerNiklas Söderlund <niklas.soderlund@ragnatech.se>2019-03-14 15:59:00 +0100
commit86a1900657db9448a42593373f62fd7e9db3c6db (patch)
treee309a6c04c211d427ca80ca5d4e88b45b93d7aa4 /test/camera/meson.build
parent823fc8e25b41a42769421f27f39fab454e1339fc (diff)
test: camera: Add read default configuration test
Add a test to verify reading the default configuration from a camera works. Signed-off-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'test/camera/meson.build')
-rw-r--r--test/camera/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/test/camera/meson.build b/test/camera/meson.build
new file mode 100644
index 00000000..186ba211
--- /dev/null
+++ b/test/camera/meson.build
@@ -0,0 +1,12 @@
+# Tests are listed in order of complexity.
+# They are not alphabetically sorted.
+camera_tests = [
+ [ 'configuration_default', 'configuration_default.cpp' ],
+]
+
+foreach t : camera_tests
+ exe = executable(t[0], [t[1], 'camera_test.cpp'],
+ link_with : test_libraries,
+ include_directories : test_includes_internal)
+ test(t[0], exe, suite: 'camera', is_parallel: false)
+endforeach