summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index 243dd3c1..6727a777 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -95,7 +95,9 @@ libcamera_sources += control_sources
gen_version = meson.source_root() / 'utils' / 'gen-version.sh'
-version_cpp = vcs_tag(command : [gen_version, meson.build_root()],
+# Use vcs_tag() and not configure_file() or run_command(), to ensure that the
+# version gets updated with every ninja build and not just at meson setup time.
+version_cpp = vcs_tag(command : [gen_version, meson.build_root(), meson.source_root()],
input : 'version.cpp.in',
output : 'version.cpp',
fallback : meson.project_version())