summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
authorNaushir Patuck <naush@raspberrypi.com>2021-10-18 10:29:41 +0100
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2021-10-19 13:14:54 +0300
commit54637a615dcdac20f1f61a017d3bae429aa389e4 (patch)
tree97020ff4dfb5ec24aa88b4e8ba6991b3d5c36e00 /src/libcamera/meson.build
parent40d994778127cc95b0c019017500695e88b4ca44 (diff)
utils: gen-version: Pass the meson source root to the gen-version.sh script
The gen-version.sh script expects to be called from a git repo, and sets its src_root variable accordingly. This may not always be the case if it is built from a tarball source - full support for which is in a future commit. The MESON_SOURCE_ROOT environnement variable does not get set when called from the meson vcs_tag() function, but does when called from the run_command() function, so that cannot be used either. Instead, explicitly pass the meson source root to the gen-version.sh script. Signed-off-by: Naushir Patuck <naush@raspberrypi.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index 243dd3c1..6727a777 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -95,7 +95,9 @@ libcamera_sources += control_sources
gen_version = meson.source_root() / 'utils' / 'gen-version.sh'
-version_cpp = vcs_tag(command : [gen_version, meson.build_root()],
+# Use vcs_tag() and not configure_file() or run_command(), to ensure that the
+# version gets updated with every ninja build and not just at meson setup time.
+version_cpp = vcs_tag(command : [gen_version, meson.build_root(), meson.source_root()],
input : 'version.cpp.in',
output : 'version.cpp',
fallback : meson.project_version())