summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 13d88301..46eb1b46 100644
--- a/meson.build
+++ b/meson.build
@@ -148,8 +148,7 @@ endif
# Create a symlink from the build root to the source root. This is used when
# running libcamera from the build directory to locate resources in the source
# directory (such as IPA configuration files).
-run_command('ln', '-fsT', meson.source_root(),
- join_paths(meson.build_root(), 'source'))
+run_command('ln', '-fsT', meson.source_root(), meson.build_root() / 'source')
configure_file(output : 'config.h', configuration : config_h)