summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorUmang Jain <umang.jain@ideasonboard.com>2021-05-07 11:28:40 +0530
committerKieran Bingham <kieran.bingham@ideasonboard.com>2021-05-11 11:50:45 +0100
commit17bf7df22762b0ecb64d0c72baed608a90363199 (patch)
tree70144f7932e8b2e7b1ee7f83c1852c4ccf7faffd /meson.build
parent99feb66df02988831c9e8535649b99fad9a78069 (diff)
meson: Replace obselete join_paths() with '/' operator
Since meson v0.49.0, join_paths() is equivalent to '/' hence, drop and replace it with '/' short-hand in meson files. This commit does not introduce any functional changes. Signed-off-by: Umang Jain <umang.jain@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 13d88301..46eb1b46 100644
--- a/meson.build
+++ b/meson.build
@@ -148,8 +148,7 @@ endif
# Create a symlink from the build root to the source root. This is used when
# running libcamera from the build directory to locate resources in the source
# directory (such as IPA configuration files).
-run_command('ln', '-fsT', meson.source_root(),
- join_paths(meson.build_root(), 'source'))
+run_command('ln', '-fsT', meson.source_root(), meson.build_root() / 'source')
configure_file(output : 'config.h', configuration : config_h)