summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index df9099d0..e86673dd 100644
--- a/meson.build
+++ b/meson.build
@@ -164,6 +164,18 @@ liblttng = dependency('lttng-ust', required : get_option('tracing'))
# are enabled.
pipelines = get_option('pipelines')
+if pipelines.contains('all')
+ pipelines = [
+ 'imx8-isi',
+ 'ipu3',
+ 'raspberrypi',
+ 'rkisp1',
+ 'simple',
+ 'uvcvideo',
+ 'vimc',
+ ]
+endif
+
if pipelines.contains('auto')
host_cpu = host_machine.cpu_family()
pipelines = []