summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPaul Elder <paul.elder@ideasonboard.com>2022-12-28 16:42:42 -0600
committerPaul Elder <paul.elder@ideasonboard.com>2022-12-30 20:03:36 -0600
commit0081e4e6b2941ea47fdf3959696d8edc2629477c (patch)
tree9b39d5c71f1caa3f441ff2c7a6b8890275b16300 /meson.build
parente1b81401cafa2e071b0903c0afe8363e84c11ede (diff)
meson: Add 'all' choice to pipelines option
Add an 'all' choice to the pipelines option, for building all pipelines. Signed-off-by: Paul Elder <paul.elder@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Umang Jain <umang.jain@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index df9099d0..e86673dd 100644
--- a/meson.build
+++ b/meson.build
@@ -164,6 +164,18 @@ liblttng = dependency('lttng-ust', required : get_option('tracing'))
# are enabled.
pipelines = get_option('pipelines')
+if pipelines.contains('all')
+ pipelines = [
+ 'imx8-isi',
+ 'ipu3',
+ 'raspberrypi',
+ 'rkisp1',
+ 'simple',
+ 'uvcvideo',
+ 'vimc',
+ ]
+endif
+
if pipelines.contains('auto')
host_cpu = host_machine.cpu_family()
pipelines = []