summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-10-13 22:22:04 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-10-15 16:49:55 +0300
commitf391048a7b987a149d0ba5421846b9b5ab916338 (patch)
treede82297ab5c83cc530d51bd9e76040f6d0b909f3 /test/meson.build
parentce739e616c42105e5c6f22bf4df5dc19b5e8c8f9 (diff)
libcamera: utils: Add hex stream output helper
Add a utils::hex() function that simplifies writing hexadecimal values to an ostream. The function handles the '0x' prefix, the field width and the fill character automatically. Use it through the libcamera code base, and add a test. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Reviewed-by: Jacopo Mondi <jacopo@jmondi.org>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index 84722cce..cf5eb84d 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -30,6 +30,7 @@ internal_tests = [
['threads', 'threads.cpp'],
['timer', 'timer.cpp'],
['timer-thread', 'timer-thread.cpp'],
+ ['utils', 'utils.cpp'],
]
foreach t : public_tests