summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorSebastian Fricke <sebastian.fricke@posteo.net>2021-01-26 19:48:54 +0100
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2021-02-04 21:00:38 +0200
commite09c487b97f8cd78944cc27ea28723622aed080b (patch)
tree32cf969c97dc374c50d62b6df62b3e3b7ba87b8b /test/meson.build
parentd121f6c83f3da5ea6a58556a64d50354ea8efd35 (diff)
test: Add unit tests for the BayerFormat class
Test all of the present methods including the newly implemented `fromV4L2PixelFormat`, as well as the new operators `==/!=`. Reviewed-by: Jacopo Mondi <jacopo@jmondi.org> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: David Plowman <david.plowman@raspberrypi.com> Signed-off-by: Sebastian Fricke <sebastian.fricke@posteo.net> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index 065c5586..89e6ebff 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -27,6 +27,7 @@ public_tests = [
]
internal_tests = [
+ ['bayer-format', 'bayer-format.cpp'],
['byte-stream-buffer', 'byte-stream-buffer.cpp'],
['camera-sensor', 'camera-sensor.cpp'],
['delayed_contols', 'delayed_contols.cpp'],