summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorStefan Klug <stefan.klug@ideasonboard.com>2025-04-03 17:49:11 +0200
committerStefan Klug <stefan.klug@ideasonboard.com>2025-05-20 09:49:01 +0200
commitdacbcc7d7779e5faec243b51b1581d401954ddea (patch)
tree39552f8b3bb9bb000f804c777a7f3867788f29ce /test/meson.build
parent6287ceff5aba1e8207aafdae9f967c70d9aad19f (diff)
test: Add minimal test for Matrix
Add a few tests for the Matrix class. This is not full fledged but at least a starter. Signed-off-by: Stefan Klug <stefan.klug@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Paul Elder <paul.elder@ideasonboard.com>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index 40956649..52f04364 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -60,6 +60,7 @@ internal_tests = [
{'name': 'file', 'sources': ['file.cpp']},
{'name': 'flags', 'sources': ['flags.cpp']},
{'name': 'hotplug-cameras', 'sources': ['hotplug-cameras.cpp']},
+ {'name': 'matrix', 'sources': ['matrix.cpp']},
{'name': 'message', 'sources': ['message.cpp']},
{'name': 'object', 'sources': ['object.cpp']},
{'name': 'object-delete', 'sources': ['object-delete.cpp']},