summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorJacopo Mondi <jacopo@jmondi.org>2018-12-30 00:00:45 +0100
committerJacopo Mondi <jacopo@jmondi.org>2018-12-31 19:01:35 +0100
commitb43f56c46d65cc983936498492a85e7e377c212b (patch)
tree8e7591cb00ab5afee6acfd8658588eda8a2c388a /test/meson.build
parent363824662f1246dff09434ae5c1ae63025bc3c22 (diff)
test: Add media device test
Add media device test infrastructure and an intial test that print out the media devices available in the system. Signed-off-by: Jacopo Mondi <jacopo@jmondi.org>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index a74629f8..6233d2c0 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -3,6 +3,7 @@ libtest_sources = files([
])
libtest = static_library('libtest', libtest_sources)
+libtest_includes = include_directories('./')
test_init = executable('test_init', 'init.cpp',
link_with : libcamera,
@@ -12,5 +13,8 @@ list = executable('list', 'list.cpp',
link_with : [libcamera, libtest],
include_directories : libcamera_includes)
+subdir('media_device')
+
test('Initialisation test', test_init)
test('List Camera API tests', list)
+test('Media Device Test', media_device_test)