summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2018-12-04 23:38:48 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2018-12-06 16:34:01 +0200
commit913b3ee817a34bd78d5a8dc4fc9025920202db09 (patch)
treef8d4bde59d0df93d2e8002dd38b35fe1e8199e38 /test/meson.build
parent0713202dc00df8aa4d2101d923546bff18d51921 (diff)
Overhaul the directory structure
In order to match the directory structure of traditional projects, rename the top-level lib/ directory to src/libcamera/. Other libraries developed as part of the project will later find a home in src/. Split the libcamera header files in three categories: public headers describing the public API in include/libcamera/, internal headers describing the internal API in src/libcamera/include/, and private headers local to one or a small number of compilation units along the corresponding .cpp files. As no internal header exists yet the src/libcamera/include/ directory is created empty as the build system would fail otherwise. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/meson.build b/test/meson.build
index afe9bd9a..924a26f1 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -1,5 +1,5 @@
test_init = executable('test_init', 'init.cpp',
link_with : libcamera,
- include_directories : inc)
+ include_directories : libcamera_includes)
test('Initialisation test', test_init)