summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-01-23 10:16:26 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-01-23 18:51:56 +0200
commit83c73c39c5c6b115fc80e6133433b70753499bab (patch)
treef1d86be30ad3b5fa966ce42e163e1a73ad69db9a /test/meson.build
parentd32dc0c1c85325926d20044141d5b9850b9433fd (diff)
tests: Test event dispatcher interruption by signal
Add a test to verify that the event dispatcher correctly restarts event processing when interrupted by a signal. The test currently fails as this feature isn't implemented. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build9
1 files changed, 5 insertions, 4 deletions
diff --git a/test/meson.build b/test/meson.build
index 8cdcae2c..d515a716 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -5,10 +5,11 @@ subdir('pipeline')
subdir('v4l2_device')
public_tests = [
- ['event', 'event.cpp'],
- ['list-cameras', 'list-cameras.cpp'],
- ['signal', 'signal.cpp'],
- ['timer', 'timer.cpp'],
+ ['event', 'event.cpp'],
+ ['event-dispatcher', 'event-dispatcher.cpp'],
+ ['list-cameras', 'list-cameras.cpp'],
+ ['signal', 'signal.cpp'],
+ ['timer', 'timer.cpp'],
]
internal_tests = [