summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2018-12-19 11:45:45 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-01-02 03:28:19 +0200
commit7e9e508093bfa22635155352e73a31efdf457419 (patch)
tree26caacb034107cef9ffda8e5cdb656d227bd52cb /test/meson.build
parenta591cc86555445a3cb3c11cb6e9a0489ea43d894 (diff)
libcamera: Remove libcamera class
The class was just a placeholder, now that we have other objects defined, remove it along with the associated test. The libcamera/libcamera.h header is kept as a shortcut to include the whole libcamera public API. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build5
1 files changed, 0 insertions, 5 deletions
diff --git a/test/meson.build b/test/meson.build
index aabe79dd..1394395c 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -12,16 +12,11 @@ test_includes_internal = [
libcamera_internal_includes,
]
-test_init = executable('test_init', 'init.cpp',
- link_with : test_libraries,
- include_directories : test_includes_public)
-
list = executable('list', 'list.cpp',
link_with : test_libraries,
include_directories : test_includes_public)
subdir('media_device')
-test('Initialisation test', test_init)
test('List Camera API tests', list)
test('Media Device Test', media_device_test)