summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorJacopo Mondi <jacopo.mondi@ideasonboard.com>2023-10-19 16:01:29 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2023-10-23 16:06:05 +0300
commit69b2dc16a09a111d8053c5d8009207cef357bcc5 (patch)
tree4253a9be7ef44c8914cb078c88c59bbc976e1e8c /test/meson.build
parent8bb0f472c3c23963fa72396caa818931ee416407 (diff)
test: Add unit test for Transform and Orientation
Add a unit test for Transform and Orientation to validate the implementation of the operations between the two types. In particular, test that: o1 / o2 = t o2 * t = o1 Signed-off-by: Jacopo Mondi <jacopo.mondi@ideasonboard.com> Reviewed-by: David Plowman <david.plowman@raspberrypi.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index b227be81..189e1428 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -46,6 +46,7 @@ public_tests = [
{'name': 'public-api', 'sources': ['public-api.cpp']},
{'name': 'signal', 'sources': ['signal.cpp']},
{'name': 'span', 'sources': ['span.cpp']},
+ {'name': 'transform', 'sources': ['transform.cpp']},
]
internal_tests = [