summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2018-12-19 11:37:23 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2018-12-21 06:44:55 +0200
commit4114a93dff6f497e8c5fc4c2328fc2a774d9ef15 (patch)
tree9b36e64d0e43ab54f64b1858d947da254a9c2937 /test/meson.build
parent907602eab5d6071e0b979807b697e1d3fd6ac6c3 (diff)
tests: Add a base Test class
The base Test class is meant to provide infrastructure common to all tests. It is very limited for now, and should be extended with at least logging and assertion handling. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index 924a26f1..da0aea96 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -1,3 +1,9 @@
+libtest_sources = files([
+ 'test.cpp',
+])
+
+libtest = static_library('libtest', libtest_sources)
+
test_init = executable('test_init', 'init.cpp',
link_with : libcamera,
include_directories : libcamera_includes)