summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-05-23 00:14:19 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-05-23 13:56:33 +0300
commit3fac104158fcbdd7d6d7ffb34e5db77f1f9ebeb5 (patch)
treef7ac0853bb9a3105d36629a268fb95d32e11c47a /test/meson.build
parent41adc3f8d39e78eb432bf33ab859d1f5429b85dc (diff)
meson: Create and use a dependency for libcamera and its headers
Instead of manually adding the libcamera library and include path to every target that requires it, declare a dependency that groups the headers as source, the library and the include path, and use it through the project. This simplifies handling of the dependency. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index ef413679..609aeab8 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -21,6 +21,7 @@ internal_tests = [
foreach t : public_tests
exe = executable(t[0], t[1],
+ dependencies : libcamera_dep,
link_with : test_libraries,
include_directories : test_includes_public)
@@ -29,6 +30,7 @@ endforeach
foreach t : internal_tests
exe = executable(t[0], t[1],
+ dependencies : libcamera_dep,
link_with : test_libraries,
include_directories : test_includes_internal)