summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2022-10-05 21:16:13 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2022-10-07 17:05:33 +0300
commit2ee8faf3c89e8f5f3f7d9693d3ed8cd892bcb5ec (patch)
tree0d2ff3320e3dbbd39b9f62a4337cccb06f91351c /test/meson.build
parentc09ca91ae51252a77873fb2947928c0e35063c59 (diff)
test: Rename 't' to 'test' in meson.build
The 't' name is very short and not very explicit. Rename it to 'test' instead. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Jacopo Mondi <jacopo@jmondi.org> Reviewed-by: Umang Jain <umang.jain@ideasonboard.com>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build30
1 files changed, 15 insertions, 15 deletions
diff --git a/test/meson.build b/test/meson.build
index 9bf7bf34..4bc01d78 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -64,44 +64,44 @@ internal_non_parallel_tests = [
['mapped-buffer', 'mapped-buffer.cpp'],
]
-foreach t : public_tests
+foreach test : public_tests
deps = [libcamera_public]
- if t.length() > 2
- deps += t[2]
+ if test.length() > 2
+ deps += test[2]
endif
- exe = executable(t[0], t[1],
+ exe = executable(test[0], test[1],
dependencies : deps,
link_with : test_libraries,
include_directories : test_includes_public)
- test(t[0], exe)
+ test(test[0], exe)
endforeach
-foreach t : internal_tests
+foreach test : internal_tests
deps = [libcamera_private]
- if t.length() > 2
- deps += t[2]
+ if test.length() > 2
+ deps += test[2]
endif
- exe = executable(t[0], t[1],
+ exe = executable(test[0], test[1],
dependencies : deps,
link_with : test_libraries,
include_directories : test_includes_internal)
- test(t[0], exe)
+ test(test[0], exe)
endforeach
-foreach t : internal_non_parallel_tests
+foreach test : internal_non_parallel_tests
deps = [libcamera_private]
- if t.length() > 2
- deps += t[2]
+ if test.length() > 2
+ deps += test[2]
endif
- exe = executable(t[0], t[1],
+ exe = executable(test[0], test[1],
dependencies : deps,
link_with : test_libraries,
include_directories : test_includes_internal)
- test(t[0], exe, is_parallel : false)
+ test(test[0], exe, is_parallel : false)
endforeach