summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorNiklas Söderlund <niklas.soderlund@ragnatech.se>2018-12-20 16:41:50 +0100
committerNiklas Söderlund <niklas.soderlund@ragnatech.se>2018-12-31 00:58:32 +0100
commit20d15d9dc47fcfbf1f02689cc4c882115abe507f (patch)
treedeadb8a32a52896b0b831cc1d0d45f75ccb6dbba /test/meson.build
parent167f751701d838538c656b9ae2b566e005489f6c (diff)
tests: add test to list all cameras in the system
Add simple test which lists all cameras detected in the system. The test fails if no camera can be found. Signed-off-by: Niklas Söderlund <niklas.soderlund@ragnatech.se>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index da0aea96..a74629f8 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -8,4 +8,9 @@ test_init = executable('test_init', 'init.cpp',
link_with : libcamera,
include_directories : libcamera_includes)
+list = executable('list', 'list.cpp',
+ link_with : [libcamera, libtest],
+ include_directories : libcamera_includes)
+
test('Initialisation test', test_init)
+test('List Camera API tests', list)