summaryrefslogtreecommitdiff
path: root/test/libtest/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2018-12-20 15:40:37 +0000
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-01-01 18:24:22 +0200
commit3900b0771ecb160f26a24b4a9bf72e827256e7da (patch)
tree7955c54f01b6f65aa664f1399e36eba7eb1347ab /test/libtest/meson.build
parentb43f56c46d65cc983936498492a85e7e377c212b (diff)
test: Move test objects to libtest
Create a subdirectory to contain the libtest helper library. Define two variables to clarify when tests are aimed at public or internal components. Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'test/libtest/meson.build')
-rw-r--r--test/libtest/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/test/libtest/meson.build b/test/libtest/meson.build
new file mode 100644
index 00000000..b998154d
--- /dev/null
+++ b/test/libtest/meson.build
@@ -0,0 +1,7 @@
+libtest_sources = files([
+ 'test.cpp',
+])
+
+libtest = static_library('libtest', libtest_sources)
+
+libtest_includes = include_directories('.')