summaryrefslogtreecommitdiff
path: root/test/camera/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-10-27 19:20:39 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-11-20 21:47:20 +0200
commitfac471e812a988905aa2c6a0914f5fc9a72ee111 (patch)
tree972d09ff4043130d3b8d31f7cf53bdc26e5c51cc /test/camera/meson.build
parent6b3308ba1b15a5be6df8fc34315cc896b077d0d0 (diff)
test: Extract CameraTest class out of camera tests to libtest
Many tests other than the camera/ tests use a camera. To increase code sharing, move the base CameraTest class to the test library. The class becomes a helper that doesn't inherit from Test anymore (to avoid diamond inheritance issues when more such helpers will exist). Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se>
Diffstat (limited to 'test/camera/meson.build')
-rw-r--r--test/camera/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/camera/meson.build b/test/camera/meson.build
index d6fd66b8..e2a6660a 100644
--- a/test/camera/meson.build
+++ b/test/camera/meson.build
@@ -9,7 +9,7 @@ camera_tests = [
]
foreach t : camera_tests
- exe = executable(t[0], [t[1], 'camera_test.cpp'],
+ exe = executable(t[0], t[1],
dependencies : libcamera_dep,
link_with : test_libraries,
include_directories : test_includes_internal)