summaryrefslogtreecommitdiff
path: root/test/camera/meson.build
diff options
context:
space:
mode:
authorNiklas Söderlund <niklas.soderlund@ragnatech.se>2019-03-06 03:12:40 +0100
committerNiklas Söderlund <niklas.soderlund@ragnatech.se>2019-03-14 15:59:17 +0100
commitaf2144231eef8bc738b9de4acd2c41e296ae6ede (patch)
tree7ed5f8e2fc1e2d5055f60f07779bde40c2a64d1c /test/camera/meson.build
parentf873d801ddd1e040e27e9aed80c63e822a2321d7 (diff)
test: camera: Add state machine test
Add a test of the different access level enforced by the state machine inside the camera. The state machine aims to limit operations on the camera to the cameras state. The test exercises all states of the camera and verifies that only the intended operations are possible at each stage. Signed-off-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'test/camera/meson.build')
-rw-r--r--test/camera/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/camera/meson.build b/test/camera/meson.build
index a1fd2032..c4427945 100644
--- a/test/camera/meson.build
+++ b/test/camera/meson.build
@@ -3,6 +3,7 @@
camera_tests = [
[ 'configuration_default', 'configuration_default.cpp' ],
[ 'configuration_set', 'configuration_set.cpp' ],
+ [ 'statemachine', 'statemachine.cpp' ],
[ 'capture', 'capture.cpp' ],
]