summaryrefslogtreecommitdiff
path: root/test/camera/meson.build
diff options
context:
space:
mode:
authorNiklas Söderlund <niklas.soderlund@ragnatech.se>2019-03-06 01:35:00 +0100
committerNiklas Söderlund <niklas.soderlund@ragnatech.se>2019-03-14 15:59:13 +0100
commitf873d801ddd1e040e27e9aed80c63e822a2321d7 (patch)
tree02f2efbbf0957c31288b1c67889bf079aa520e06 /test/camera/meson.build
parente44b63b3777df767d1e49f4e0ec2067b3638793f (diff)
test: camera: Add capture test
Correctly configure the camera using the default configuration and run a capture session for 100 milliseconds, which is plenty of time, in tests over 600 requests completed using the vimc pipeline. The test passes if at least the number of buffers used in the capture times two number of requests completes to prove we cycle through all buffers. Signed-off-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'test/camera/meson.build')
-rw-r--r--test/camera/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/camera/meson.build b/test/camera/meson.build
index ed483719..a1fd2032 100644
--- a/test/camera/meson.build
+++ b/test/camera/meson.build
@@ -3,6 +3,7 @@
camera_tests = [
[ 'configuration_default', 'configuration_default.cpp' ],
[ 'configuration_set', 'configuration_set.cpp' ],
+ [ 'capture', 'capture.cpp' ],
]
foreach t : camera_tests