summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-03-29 04:48:59 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-04-14 02:03:09 +0300
commitec9231889156fc9b5debcdb99605fe32964ebaaa (patch)
treebce651032ef06ecdad3e705a087cb518ad8e4d95 /src/meson.build
parente62bc9db73531462dc4b28b42596d0ae26369cbd (diff)
libcamera: Add IPA module signing infrastructure
Add infrastructure to generate an RSA private key and sign IPA modules. The signatures are stored in separate files with a .sign suffix. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
index d818d8b8..dc0e0c82 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -2,6 +2,11 @@ if get_option('android')
subdir('android')
endif
+ipa_gen_priv_key = find_program('ipa/gen-ipa-priv-key.sh')
+ipa_priv_key = custom_target('ipa-priv-key',
+ output : [ 'ipa-priv-key.pem' ],
+ command : [ ipa_gen_priv_key, '@OUTPUT@' ])
+
subdir('libcamera')
subdir('ipa')
subdir('cam')