summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2021-06-24 16:33:59 +0100
committerKieran Bingham <kieran.bingham@ideasonboard.com>2021-06-25 16:09:46 +0100
commitec7afef665a87eb389a5a4cb9ff35e9c24bbcc29 (patch)
tree3bc1c6ac8c6a143d39f68ffa7688df93c32e364a /src/libcamera/meson.build
parentbdca9ab14ef3198b635af6043fc1d7e31be79f51 (diff)
libcamera: Rename libcamera pkg-config generation
The libcamera library is moved to the first positional argument of the pkg-config generator to automatically populate the name and filebase values for the package. As part of this, the shared library name is adjusted to the full library name 'libcamera', without relying upon the automatic 'lib' prefix which better represents the component and naming of the library. As a result of this, the pkgconfig file is now named 'libcamera.pc' as opposed to 'camera.pc', and applications desiring to reference libcamera will need to search for 'libcamera' as a dependency rather than 'camera'. The library itself is still created and installed as 'libcamera.so'. An example meson.build file would need to be adjusted as the following: - dependency('camera', required : true), + dependency('libcamera', required : true), Reviewed-by: Paul Elder <paul.elder@ideasonboard.com> Reviewed-by: Hirokazu Honda <hiroh@chromium.org> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build7
1 files changed, 3 insertions, 4 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index e4c60e73..387d2084 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -135,8 +135,9 @@ libcamera_deps = [
# runtime if the library is running from an installed location by checking
# for the presence or abscence of the dynamic tag.
-libcamera = shared_library('camera',
+libcamera = shared_library('libcamera',
libcamera_sources,
+ name_prefix : '',
install : true,
include_directories : includes,
build_rpath : '/',
@@ -157,10 +158,8 @@ libcamera_dep = declare_dependency(sources : [
link_with : libcamera)
pkg_mod = import('pkgconfig')
-pkg_mod.generate(libraries: libcamera,
+pkg_mod.generate(libcamera,
version : '1.0',
- name : 'libcamera',
- filebase : 'camera',
description : 'Complex Camera Support Library',
subdirs : 'libcamera')