summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2021-06-24 14:41:15 +0100
committerKieran Bingham <kieran.bingham@ideasonboard.com>2021-06-25 16:09:46 +0100
commitbdca9ab14ef3198b635af6043fc1d7e31be79f51 (patch)
tree6bf22c3e825e920defc81b5c0d3f3a823fe0a723 /src/libcamera/meson.build
parent1ad25efa60c131a0386f251431c2f11d41f4e009 (diff)
libcamera: Move libcamera.so pkg-config file generation
The pkg-config file for the main libcamera.so is generated at the top level meson.build. Move this to the actual core libcamera build structure to be consistent and keep it next to the library construction. Reviewed-by: Paul Elder <paul.elder@ideasonboard.com> Reviewed-by: Hirokazu Honda <hiroh@chromium.org> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index d9b5bfae..e4c60e73 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -156,4 +156,12 @@ libcamera_dep = declare_dependency(sources : [
include_directories : libcamera_includes,
link_with : libcamera)
+pkg_mod = import('pkgconfig')
+pkg_mod.generate(libraries: libcamera,
+ version : '1.0',
+ name : 'libcamera',
+ filebase : 'camera',
+ description : 'Complex Camera Support Library',
+ subdirs : 'libcamera')
+
subdir('proxy/worker')