summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2021-02-08 23:14:05 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2021-02-11 18:20:49 +0200
commite36a6f40433ce661610f34ed2db31e82e22c579d (patch)
treefcf309891c4a3d66ce1f09d64197f1e89fc32032 /src/libcamera/meson.build
parentdb27029ce45b8c523aaaceb4ab1027cade228ebd (diff)
libcamera: Drop unneeded depend_files from meson custom targets
The meson custom_target() function accepts a 'depend_files' argument to list additional dependency files. Files already listed in the 'command' argument are handled automatically, and don't need to be added manually. Drop them. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index 2b185089..ebce19d9 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -94,7 +94,6 @@ foreach source : control_source_files
control_sources += custom_target(source + '_cpp',
input : input_files,
output : source + '.cpp',
- depend_files : gen_controls,
command : [gen_controls, '-o', '@OUTPUT@', '@INPUT@'])
endforeach