summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-05-23 00:14:19 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-05-23 13:56:33 +0300
commit3fac104158fcbdd7d6d7ffb34e5db77f1f9ebeb5 (patch)
treef7ac0853bb9a3105d36629a268fb95d32e11c47a /src/libcamera/meson.build
parent41adc3f8d39e78eb432bf33ab859d1f5429b85dc (diff)
meson: Create and use a dependency for libcamera and its headers
Instead of manually adding the libcamera library and include path to every target that requires it, declare a dependency that groups the headers as source, the library and the include path, and use it through the project. This simplifies handling of the dependency. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index 8294ed35..0ebb25bc 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -65,3 +65,7 @@ libcamera = shared_library('camera',
install : true,
include_directories : includes,
dependencies : libudev)
+
+libcamera_dep = declare_dependency(sources : libcamera_api,
+ include_directories : libcamera_includes,
+ link_with : libcamera)