summaryrefslogtreecommitdiff
path: root/src/ipa/meson.build
diff options
context:
space:
mode:
authorQuentin Schulz <quentin.schulz@theobroma-systems.com>2022-07-26 15:20:51 +0200
committerJacopo Mondi <jacopo@jmondi.org>2022-07-26 17:09:55 +0200
commitc698473440abee7330c76d2370c3c01ecc48b8e3 (patch)
tree740b9b24328295b164db661e886bfee398ed33d1 /src/ipa/meson.build
parent49e85fbe9c3bf59c99f7d764abc9a7294e8b5e91 (diff)
libcamera: Correctly report enabled ipa modules
"ipa_modules" stores the value of the ipas meson build option. IPAs are enabled if and only if there is an enabled pipeline for an IPA listed in "ipa_modules" array. It is basically the intersection of pipelines and ipa_modules array. In order to correctly report which IPAs get enabled, let's create a new array storing this intersection. Cc: Quentin Schulz <foss+libcamera@0leil.net> Reported-by: Daniel Semkowicz <dse@thaumatec.com> Signed-off-by: Quentin Schulz <quentin.schulz@theobroma-systems.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Jacopo Mondi <jacopo@jmondi.org> Signed-off-by: Jacopo Mondi <jacopo@jmondi.org>
Diffstat (limited to 'src/ipa/meson.build')
-rw-r--r--src/ipa/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/ipa/meson.build b/src/ipa/meson.build
index e15a8a06..849bb372 100644
--- a/src/ipa/meson.build
+++ b/src/ipa/meson.build
@@ -27,6 +27,7 @@ ipa_sign = files('ipa-sign.sh')
ipa_names = []
ipa_modules = get_option('ipas')
+enabled_ipa_modules = []
# The ipa-sign-install.sh script which uses the ipa_names variable will itself
# prepend MESON_INSTALL_DESTDIR_PREFIX to each ipa module name, therefore we
@@ -35,6 +36,7 @@ foreach pipeline : pipelines
if ipa_modules.contains(pipeline)
subdir(pipeline)
ipa_names += ipa_install_dir / ipa_name + '.so'
+ enabled_ipa_modules += pipeline
endif
endforeach