summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2021-06-24 14:41:15 +0100
committerKieran Bingham <kieran.bingham@ideasonboard.com>2021-06-25 16:09:46 +0100
commitbdca9ab14ef3198b635af6043fc1d7e31be79f51 (patch)
tree6bf22c3e825e920defc81b5c0d3f3a823fe0a723 /meson.build
parent1ad25efa60c131a0386f251431c2f11d41f4e009 (diff)
libcamera: Move libcamera.so pkg-config file generation
The pkg-config file for the main libcamera.so is generated at the top level meson.build. Move this to the actual core libcamera build structure to be consistent and keep it next to the library construction. Reviewed-by: Paul Elder <paul.elder@ideasonboard.com> Reviewed-by: Hirokazu Honda <hiroh@chromium.org> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 0 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 4d7d936f..6eed0d8c 100644
--- a/meson.build
+++ b/meson.build
@@ -164,14 +164,6 @@ run_command('ln', '-fsT', meson.source_root(), meson.build_root() / 'source')
configure_file(output : 'config.h', configuration : config_h)
-pkg_mod = import('pkgconfig')
-pkg_mod.generate(libraries : libcamera,
- version : '1.0',
- name : 'libcamera',
- filebase : 'camera',
- description : 'Complex Camera Support Library',
- subdirs : 'libcamera')
-
# Check for python installation and modules.
py_mod = import('python')
py_mod.find_installation('python3', modules: py_modules)