summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2021-05-10 17:00:57 +0530
committerUmang Jain <umang.jain@ideasonboard.com>2021-06-28 14:12:06 +0530
commit249b42db7cd39d7ec20094242cd7a8c41ea3b442 (patch)
tree57fbc62da85337a020e4cf75615b242a7e4fd639 /meson.build
parentf21b9306a7893017b9f7e6b95001da9abade30f7 (diff)
aiq: Provide a BinaryData wrapper
The AIQ class loads data as instances of ia_binary_data. The data for this structure should be loaded from files, and the lifetime of the data is managed by the lifetime of the class. Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Signed-off-by: Umang Jain <umang.jain@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 683af0e..5be3a94 100644
--- a/meson.build
+++ b/meson.build
@@ -50,6 +50,7 @@ common_arguments = [
ipa_includes = [
include_directories('include'),
include_directories('include/ia_imaging'),
+ include_directories('.'),
]
c_arguments = []
@@ -80,6 +81,7 @@ add_project_arguments(c_arguments, language : 'c')
add_project_arguments(cpp_arguments, language : 'cpp')
ipu3_ipa_files = files([
+ 'binary_data.cpp',
'ipu3.cpp',
])