summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2020-10-30 11:58:14 +0000
committerKieran Bingham <kieran.bingham@ideasonboard.com>2024-06-10 14:19:28 +0100
commit5aa3c331d2f4a0a70f993bd9acbfda33b2ce17f3 (patch)
treed45513a134e2ff3722617ab9ca8249043549efc4 /meson.build
parentd0857a4509c4a841c5ae139cea15061709d316f7 (diff)
DocumentationUseOnly: Force enable Vivid
To make sure we always build the Vivid pipeline in this branch, explicitly add it to the pipelines build targets. This is not any kind of best practice for pipeline handlers, but is here to ensure that this pipeline is always compiled on this branch who's sole purpose is to use and demonstrate the vivid pipeline handler.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 0ef4cdaa..eb815021 100644
--- a/meson.build
+++ b/meson.build
@@ -237,6 +237,11 @@ if get_option('test')
endforeach
endif
+# Force enable the Vivid pipeline on the development branch only.
+if 'vivid' not in pipelines
+ pipelines += ['vivid']
+endif
+
# Utilities are parsed first to provide support for other components.
subdir('utils')