summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBarnabás Pőcze <pobrn@protonmail.com>2024-12-17 15:15:16 +0000
committerBarnabás Pőcze <pobrn@protonmail.com>2025-01-10 12:53:18 +0100
commit2ae7b2ff7438a4deecff2a8b5de685cc14e5cd44 (patch)
tree23863d9f753ce316338f01abd7f5125d47b1c2e8 /meson.build
parenta94553231470b3b8102981191418e61690759fba (diff)
meson: Don't override pipeline list when `auto` is selected
Consider `pipelines=auto,virtual`. Previously that would select everything that `auto` would, but not actually enable the `virtual` pipeline handler because the `pipelines` list was reset. Bug: https://bugs.libcamera.org/show_bug.cgi?id=247 Signed-off-by: Barnabás Pőcze <pobrn@protonmail.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Acked-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 6 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 06b9af94..5270f626 100644
--- a/meson.build
+++ b/meson.build
@@ -204,7 +204,7 @@ liblttng = dependency('lttng-ust', required : get_option('tracing'))
# Pipeline handlers
#
-pipelines = get_option('pipelines')
+wanted_pipelines = get_option('pipelines')
arch_arm = ['arm', 'aarch64']
arch_x86 = ['x86', 'x86_64']
@@ -220,16 +220,18 @@ pipelines_support = {
'virtual': ['test'],
}
-if pipelines.contains('all')
+if wanted_pipelines.contains('all')
pipelines = pipelines_support.keys()
-elif pipelines.contains('auto')
+elif wanted_pipelines.contains('auto')
host_cpu = host_machine.cpu_family()
pipelines = []
foreach pipeline, archs : pipelines_support
- if host_cpu in archs or 'any' in archs
+ if pipeline in wanted_pipelines or host_cpu in archs or 'any' in archs
pipelines += pipeline
endif
endforeach
+else
+ pipelines = wanted_pipelines
endif
# Tests require the vimc pipeline handler, include it automatically when tests