summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorUmang Jain <email@uajain.com>2020-12-04 13:22:23 +0530
committerKieran Bingham <kieran.bingham@ideasonboard.com>2020-12-04 10:33:05 +0000
commitb79a04afa753d5cfda47faee9bb4fc7b46c78b01 (patch)
tree3f52d090ddb1fb50a0f4d7e9b6889363753bb294 /meson.build
parent14529b6d1c4a6d405b23157eca8a4b0bec632e00 (diff)
simple-cam: Provide event-loop backed by libevent
libcamera moved its EventDispatcher and Timer API to its internal API, since providing an event loop to applications should not be the job of libcamera. Application utility like cam, were ported to use libevent, hence inspired from that, un-break simple-cam by using the similar implementation to replace the EventDispatcher and Timer functionality by libevent. Signed-off-by: Umang Jain <email@uajain.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index c312f2c..4d580c2 100644
--- a/meson.build
+++ b/meson.build
@@ -8,12 +8,14 @@ project('simple-cam', 'c', 'cpp',
# simple-cam.cpp is the fully commented application
src_files = files([
'simple-cam.cpp',
+ 'event_loop.cpp',
])
# Point your PKG_CONFIG_PATH environment variable to the
# libcamera install path camera.pc file ($prefix/lib/pkgconfig/camera.pc)
libcamera_deps = [
dependency('camera', required : true),
+ dependency('libevent_pthreads'),
]
cpp_arguments = [ '-Wno-unused-parameter', ]