summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2020-05-19 13:04:49 +0100
committerKieran Bingham <kieran.bingham@ideasonboard.com>2020-05-19 13:04:49 +0100
commit11fe7271218af5d5ebbd4a4f78d81f51956496b2 (patch)
tree0d20995ff3dc701c5ca83e5272866f146acefd44 /meson.build
parent3d2207750a88933e58dfe55b572b25613322bd54 (diff)
meson: Use array for arguments
Store any extra cpp_arguments in an array so they can be appended to when needed. Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index c25dee3..aeea801 100644
--- a/meson.build
+++ b/meson.build
@@ -19,7 +19,8 @@ libcamera_deps = [
dependency('camera', required : true),
]
-cpp_arguments = '-Wno-unused-parameter'
+cpp_arguments = [ '-Wno-unused-parameter', ]
+
add_project_arguments(cpp_arguments, language : 'cpp')
# elce-cam executable