summaryrefslogtreecommitdiff
path: root/src/ipa/simple/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/ipa/simple/meson.build')
-rw-r--r--src/ipa/simple/meson.build7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/ipa/simple/meson.build b/src/ipa/simple/meson.build
index 7757f99b..dcd7c70a 100644
--- a/src/ipa/simple/meson.build
+++ b/src/ipa/simple/meson.build
@@ -1,5 +1,8 @@
# SPDX-License-Identifier: CC0-1.0
+subdir('algorithms')
+subdir('data')
+
ipa_name = 'ipa_soft_simple'
soft_simple_sources = files([
@@ -8,6 +11,8 @@ soft_simple_sources = files([
'black_level.cpp',
])
+soft_simple_sources += soft_simple_ipa_algorithms
+
mod = shared_module(ipa_name, soft_simple_sources,
name_prefix : '',
include_directories : [ipa_includes],
@@ -24,6 +29,4 @@ if ipa_sign_module
build_by_default : true)
endif
-subdir('data')
-
ipa_names += ipa_name