summaryrefslogtreecommitdiff
path: root/include/libcamera/ipa/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'include/libcamera/ipa/meson.build')
-rw-r--r--include/libcamera/ipa/meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/include/libcamera/ipa/meson.build b/include/libcamera/ipa/meson.build
index 6ea94fb5..442ca3dd 100644
--- a/include/libcamera/ipa/meson.build
+++ b/include/libcamera/ipa/meson.build
@@ -25,8 +25,8 @@ ipa_mojom_core = custom_target(core_mojom_file.split('.')[0] + '_mojom_module',
output : core_mojom_file + '-module',
command : [
mojom_parser,
- '--output-root', meson.build_root(),
- '--input-root', meson.source_root(),
+ '--output-root', meson.project_build_root(),
+ '--input-root', meson.project_source_root(),
'--mojoms', '@INPUT@'
])
@@ -89,8 +89,8 @@ foreach file : ipa_mojom_files
depends : ipa_mojom_core,
command : [
mojom_parser,
- '--output-root', meson.build_root(),
- '--input-root', meson.source_root(),
+ '--output-root', meson.project_build_root(),
+ '--input-root', meson.project_source_root(),
'--mojoms', '@INPUT@'
])