summaryrefslogtreecommitdiff
path: root/Documentation/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'Documentation/meson.build')
-rw-r--r--Documentation/meson.build14
1 files changed, 8 insertions, 6 deletions
diff --git a/Documentation/meson.build b/Documentation/meson.build
index 1ba40fdf..0fc5909d 100644
--- a/Documentation/meson.build
+++ b/Documentation/meson.build
@@ -116,10 +116,8 @@ endif
# Sphinx
#
-sphinx = find_program('sphinx-build-3', required : false)
-if not sphinx.found()
- sphinx = find_program('sphinx-build', required : get_option('documentation'))
-endif
+sphinx = find_program('sphinx-build-3', 'sphinx-build',
+ required : get_option('documentation'))
if sphinx.found()
docs_sources = [
@@ -128,15 +126,19 @@ if sphinx.found()
'coding-style.rst',
'conf.py',
'contributing.rst',
- 'docs.rst',
+ 'design/ae.rst',
+ 'documentation-contents.rst',
'environment_variables.rst',
+ 'feature_requirements.rst',
'guides/application-developer.rst',
- 'guides/introduction.rst',
'guides/ipa.rst',
'guides/pipeline-handler.rst',
'guides/tracing.rst',
'index.rst',
+ 'introduction.rst',
'lens_driver_requirements.rst',
+ 'libcamera_architecture.rst',
+ 'mali-c55.dot',
'python-bindings.rst',
'sensor_driver_requirements.rst',
'software-isp-benchmarking.rst',