summaryrefslogtreecommitdiff
path: root/test/ipa/rkisp1/meson.build
diff options
context:
space:
mode:
authorPaul Elder <paul.elder@ideasonboard.com>2024-03-27 17:54:49 +0900
committerPaul Elder <paul.elder@ideasonboard.com>2024-05-31 17:12:48 +0900
commit9d152e9c66c1094a482e704d95965078a0fe2cf3 (patch)
treeb2fb40ead282da27a96586ef318a2482225282dc /test/ipa/rkisp1/meson.build
parentc79fa47aac9b38865dab5e9f29030903bf460c46 (diff)
ipa: rkisp1: Add a helper to convert floating-point to fixed-point
Add helper functions for converting between floating point and fixed point numbers. Also add tests for them. Signed-off-by: Paul Elder <paul.elder@ideasonboard.com> Reviewed-by: Stefan Klug <stefan.klug@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'test/ipa/rkisp1/meson.build')
-rw-r--r--test/ipa/rkisp1/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/test/ipa/rkisp1/meson.build b/test/ipa/rkisp1/meson.build
new file mode 100644
index 00000000..5ffc5dd6
--- /dev/null
+++ b/test/ipa/rkisp1/meson.build
@@ -0,0 +1,15 @@
+# SPDX-License-Identifier: CC0-1.0
+
+rkisp1_ipa_test = [
+ {'name': 'rkisp1-utils', 'sources': ['rkisp1-utils.cpp']},
+]
+
+foreach test : rkisp1_ipa_test
+ exe = executable(test['name'], test['sources'], libcamera_generated_ipa_headers,
+ dependencies : libcamera_private,
+ link_with : [libipa, test_libraries],
+ include_directories : [libipa_includes, test_includes_internal,
+ '../../../src/ipa/rkisp1/'])
+
+ test(test['name'], exe, suite : 'ipa')
+endforeach