summaryrefslogtreecommitdiff
path: root/test/ipa/libipa/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2024-11-18 01:11:17 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2024-11-26 19:05:19 +0200
commit4251193c3544ec105e75452c52d9c88384335df2 (patch)
treeb1ff3bb0223b4613da7cce01453a2076ed52797c /test/ipa/libipa/meson.build
parent5ad6b3b1bbd4d1c8d0e7cf38bc6dc1d29a978381 (diff)
test: libipa: Add Vector class test
Add a unit test to exercize the API of the ipa::Vector class. The test binary being called 'vector', implicit includes cause the binary to be picked by '#include <vector>', causing builds to fail. Set implicit_include_directories to false to avoid this, as done in commit 6cd849125888 ("test: Don't add current build directory to include path"). Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Milan Zamazal <mzamazal@redhat.com>
Diffstat (limited to 'test/ipa/libipa/meson.build')
-rw-r--r--test/ipa/libipa/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/test/ipa/libipa/meson.build b/test/ipa/libipa/meson.build
index 4d2427db..f9b3c46d 100644
--- a/test/ipa/libipa/meson.build
+++ b/test/ipa/libipa/meson.build
@@ -2,11 +2,13 @@
libipa_test = [
{'name': 'interpolator', 'sources': ['interpolator.cpp']},
+ {'name': 'vector', 'sources': ['vector.cpp']},
]
foreach test : libipa_test
exe = executable(test['name'], test['sources'],
dependencies : [libcamera_private, libipa_dep],
+ implicit_include_directories : false,
link_with : [test_libraries],
include_directories : [test_includes_internal,
'../../../src/ipa/libipa/'])