summaryrefslogtreecommitdiff
path: root/src/ipa/libipa/meson.build
diff options
context:
space:
mode:
authorDaniel Scally <dan.scally@ideasonboard.com>2024-05-02 14:30:42 +0100
committerKieran Bingham <kieran.bingham@ideasonboard.com>2024-05-08 12:54:56 +0100
commit24247a12c7d354087ff8a02b5dc2cc9c916f2e00 (patch)
treeb1cd9abf3cffad8c6ea501bff4305e48f02d830c /src/ipa/libipa/meson.build
parent34c9ab62827b3efe90e5e565127e55a9f8acb3b3 (diff)
ipa: libipa: Add AgcMeanLuminance base class
The Agc algorithms for the RkIsp1 and IPU3 IPAs do the same thing in very large part; following the Rpi IPA's algorithm in spirit with a few tunable values in that IPA being hardcoded in the libipa ones. Add a new base class for AgcMeanLuminance which implements the same algorithm and additionally parses yaml tuning files to inform an IPA module's Agc algorithm about valid constraint and exposure modes and their associated bounds. Reviewed-by: Jacopo Mondi <jacopo.mondi@ideasonboard.com> Reviewed-by: Stefan Klug <stefan.klug@ideasonboard.com> Reviewed-by: Paul Elder <paul.elder@ideasonboard.com> Signed-off-by: Daniel Scally <dan.scally@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/ipa/libipa/meson.build')
-rw-r--r--src/ipa/libipa/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/ipa/libipa/meson.build b/src/ipa/libipa/meson.build
index 37fbd177..7ce885da 100644
--- a/src/ipa/libipa/meson.build
+++ b/src/ipa/libipa/meson.build
@@ -1,6 +1,7 @@
# SPDX-License-Identifier: CC0-1.0
libipa_headers = files([
+ 'agc_mean_luminance.h',
'algorithm.h',
'camera_sensor_helper.h',
'exposure_mode_helper.h',
@@ -10,6 +11,7 @@ libipa_headers = files([
])
libipa_sources = files([
+ 'agc_mean_luminance.cpp',
'algorithm.cpp',
'camera_sensor_helper.cpp',
'exposure_mode_helper.cpp',