summaryrefslogtreecommitdiff
path: root/test/v4l2_videodevice/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/v4l2_videodevice/meson.build')
-rw-r--r--test/v4l2_videodevice/meson.build26
1 files changed, 13 insertions, 13 deletions
diff --git a/test/v4l2_videodevice/meson.build b/test/v4l2_videodevice/meson.build
index 7a26f53d..87ea4f96 100644
--- a/test/v4l2_videodevice/meson.build
+++ b/test/v4l2_videodevice/meson.build
@@ -3,22 +3,22 @@
# Tests are listed in order of complexity.
# They are not alphabetically sorted.
v4l2_videodevice_tests = [
- ['double_open', 'double_open.cpp'],
- ['controls', 'controls.cpp'],
- ['formats', 'formats.cpp'],
- ['dequeue_watchdog', 'dequeue_watchdog.cpp'],
- ['request_buffers', 'request_buffers.cpp'],
- ['buffer_cache', 'buffer_cache.cpp'],
- ['stream_on_off', 'stream_on_off.cpp'],
- ['capture_async', 'capture_async.cpp'],
- ['buffer_sharing', 'buffer_sharing.cpp'],
- ['v4l2_m2mdevice', 'v4l2_m2mdevice.cpp'],
+ {'name': 'double_open', 'sources': ['double_open.cpp']},
+ {'name': 'controls', 'sources': ['controls.cpp']},
+ {'name': 'formats', 'sources': ['formats.cpp']},
+ {'name': 'dequeue_watchdog', 'sources': ['dequeue_watchdog.cpp']},
+ {'name': 'request_buffers', 'sources': ['request_buffers.cpp']},
+ {'name': 'buffer_cache', 'sources': ['buffer_cache.cpp']},
+ {'name': 'stream_on_off', 'sources': ['stream_on_off.cpp']},
+ {'name': 'capture_async', 'sources': ['capture_async.cpp']},
+ {'name': 'buffer_sharing', 'sources': ['buffer_sharing.cpp']},
+ {'name': 'v4l2_m2mdevice', 'sources': ['v4l2_m2mdevice.cpp']},
]
-foreach t : v4l2_videodevice_tests
- exe = executable(t[0], [t[1], 'v4l2_videodevice_test.cpp'],
+foreach test : v4l2_videodevice_tests
+ exe = executable(test['name'], [test['sources'], 'v4l2_videodevice_test.cpp'],
dependencies : libcamera_private,
link_with : test_libraries,
include_directories : test_includes_internal)
- test(t[0], exe, suite : 'v4l2_videodevice', is_parallel : false)
+ test(test['name'], exe, suite : 'v4l2_videodevice', is_parallel : false)
endforeach